Knowledgebase
Please upgrade your JDK to 1.7 if “Server has a week ephemeral Diffe-Hellman public key” prompts
Posted by Nico Wang on 28 January 2016 02:32 PM

Some versions of Chrome or Firefox have stringent rules on SSL keys which will block the Appeon plug-in download and throw an error “Server has a week ephemeral Diffe-Hellman public key”, as shown below.

Solution: this issue occurs only when the Appeon Server is a Java application server running with JDK 1.6 or lower version. You can upgrade to JDK 1.7 to avoid this issue.

(0 votes)
This article was helpful
This article was not helpful

Comments (0)
Post a new comment 
 

Please login if you wish to leave a comment about this article.

Help Desk Software by Kayako Fusion